Will Wright's Spore > Spore: General

SPORE: Help thread for problems *please read before posting*

(1/6) > >>

We will try to help solve problems by organizing the answers to problems as they come up. The Dev team have been posting and trying to help us with answers so let's help them by containing the issues in an organized manner.

1.Please search for your problem before posting. If you don't see it, then make a new thread. If you find a thread with the same problem, then please post there.

2. Label your thread very clearly regarding the problem, do not use "OMG, please help". If your problem is installation related, then call it: Installation Problem, wont' register.

3. Remember that we are players like you and we don't have all the answers but we have kind members who like to help others. The official EA help section is located at Spore.com forums. Tech Support

If you are unsure whether someone who is trying to help is really from Maxis, please ask a moderator, we can check the IP's.

Spore Creature Creator
Creature Creator Help thread

SPORE: The Game
Invalid CD Key
Maxis is aware of the problem and is gathering more information to help fix it. Please visit the thread above for more information.

Error while installing
Q. Just picked the game up, put it in the drive, and I got an error:
Error Code:   -5005 : 0x80070002
Error Information:
>Kernel\KernelMedia.cpp (95)
>SetupNew\setup.cpp (836)
PVENDOR:Electronic Arts (http://www.ea.com)
@Windows XP Service Pack 2 (2600)  IE 7.0.6000.16711
Anyone know how to fix this?

A: It means the Creature Creator was not uninstalled. Here is a fix:

Problem: Black Screen in Custom Paint Editor iMac
Answer: Change Graphics effect settings

*Thank you to those posting your Q/A here in this thread, I'm going to leave them and let others do the same.*

Q: My PC doesn't do anything when I launch spore. The exe file is running in the background but Spore never comes up?

1) Go to the folder where you have Spore installed, then the subfolder Sporebin.
2) Right-click on SporeApp.exe and click Properties.
3) Go to the tab "Compatibility" and tick the checkbox "Run this program as Administrator". Click OK and reboot the PC.
4) It should now work, only you'll get a pop-up when you start the game asking if you really want to. Just click OK.

1) Right-click the Spore shortcut and click Properties.
2) Go to the tab "Shortcut" and click "Advanced".
3) In the pop-up, check the option "Run with different credentials". Click OK on the pop-up and again on the Properties box.
4) When you start the game from now on it will ask you to "Run As" a user. Select option 2 "The following user".
5) If your Windows account is an Administrator, then type in your Windows username and password in the dialogue box. If it is not then you have to type in the username and password of another Windows account which is Administrator.

This is a work-around, there may be another more involved solution but this one works for now. Here's hoping they'll fix the problem in the upcoming patch :)
Source: http://www.gamingsteve.com/blab/index.php?topic=14066.15

Note: If this does not work you may have conflicting software installed.
We have seen indications that other software/services may interferre with Spore launching correctly. We have no concrete evidence as to what programs might cause problems yet, so you may have to use method of elimination which is a slow but sure diagnostic method.

1) Press [Windows Key] + [R], this opens the Run command box.
2) Type in MSCONFIG and hit [Enter].
3) Go to the Services Tab > Tick the box "Hide all Microsoft services" > Click the button "Disable all".
4) Go to the Startup Tab > Click the button "Disable all" > Click "OK" > Reboot your system.
Following the above steps will disable all startup programs and non-Microsoft services from running. To revert to your normal system state, go to MSCONFIG again > General Tab > Put the dot in "Normal startup" > Click "OK" > Reboot.
The following diagnostics will assume that you haven't reverted to your normal system state.
5) Run Spore. If it is not working then it does not appear to be a software/services conflict and you can revert your system to normal as described above. Continuing these diagnostics will not help you in this case.
6) Assuming Spore worked we now know a service or a program on your PC is interferring with the function of Spore.
7) Launch MSCONFIG again and enable ONE service or ONE startup program, click "OK" and reboot.
8 ) Test Spore again. If Spore doesn't work now go to step 10. If it does work go to step 9.
9) If Spore still works, then the program/service you just enabled is not the culprit. Keep enabling more by repeating steps 7-8 until Spore stops working, in which case you go to step 10.
10) You've found the program or service causing the conflict, and can deal with it by uninstalling it or leaving it disabled while re-enabling everything else in MSCONFIG.
11) In the unlikely event that you follow step 10 and then Spore stops working again, you have several programs conflicting. Repeat 7-10 while keeping any problem causing programs/services disabled along the way.

I know this is long winded and tedious, but I thought I might as well add it in case someone is persistent enough but doesn't know how to go about it.

Q: I have an Nvidia Geforce 9800 and whenever I try to run spore it tells me to update to the latest driver, or disable one of my multiple GPU's. I have the most recent driver, what do I do?

A) First make sure your DirectX is up to date. Once that is done, go to http://www.nvidia.com/Download/Find.aspx?lang=en-us and download GeForce Release 177. It should do the trick. It is a beta driver, so use at your own risk, but Nvidia should be putting out an official driver soon that will allow people to use thier fancy new Nvidia cards with Spore.

Patch problems: Audio, bugs etc. This seems to have helped all post-patch problems.

--- Quote from: Lucky on September 29, 2008, 05:49:34 pm ---Good news - we think that we may have figured this out.   A temporary workaround is:

If you are experiencing the lag issue, please try adding -jobPriority:0 to the command line (Make a shortcut on your desktop, right-click and select Properties, and add the -jobPriority:0 to the Target line).

We have had reports of this improving the problem.

We are planning to address this with a more permanent solution.

Thanks -


--- End quote ---

I'm having trouble with in-game screen capture. I was able to do this before installing the latest patch, but now my game crashes every time I hit the 'C' key while I'm in-game.
I'd very much appreciate any advice. Thanks.


[0] Message Index

[#] Next page

Go to full version