Gaming Steve Message Board

Will Wright's Spore => Spore: General => Topic started by: Bama on September 09, 2008, 10:38:06 pm

Title: Game Crashing Bug
Post by: Bama on September 09, 2008, 10:38:06 pm
When I try to enter the last star system of a race to kill the raceit crashes everytime i try to go to planet level.
Title: Re: Game Crashing Bug
Post by: DaMuncha on September 09, 2008, 10:42:23 pm
I've only ever crashed once, and that was when I wiped out the last of my enemies planets (home).
Title: Re: Game Crashing Bug
Post by: Doomsday on September 09, 2008, 10:53:59 pm
When I try to enter the last star system of a race to kill the raceit crashes everytime i try to go to planet level.

odd.. I had no issue when I did this.. perhaps it's an issue with that particular planet/race? Have you been there previously? Did you issue an ally to attack it?
Title: Re: Game Crashing Bug
Post by: Bama on September 09, 2008, 11:49:48 pm
I dont even know to be honest...i was playing a long time and my mind fried haha
Title: Re: Game Crashing Bug
Post by: Alvin Flummox on September 10, 2008, 12:34:23 am
Yeah my game crashes sometimes when I press ctrl + z when im painting something in one of the editors.
Its starting to get really annoying now :-\
Title: Re: Game Crashing Bug
Post by: Necrox on September 10, 2008, 02:27:14 am
I get freeze/crashes too (roughly once every one or two hours) and it's usually when entering or leaving a planet.
Title: Re: Game Crashing Bug
Post by: 0d1n3oo3Broad on September 10, 2008, 03:59:43 am
My game crashes after i defended my homeworld against invaders and i want to go to orbit. In all other cases it works, except after the invasion. And this problem exists only for my homeworld. When i defend one of my colonies and go after that into orbit it works just fine.

But it works again for some time when i delete the ...\AppData\Roaming\SPORE\MVJCache-folder and the GraphicsCache.package-file.
Title: Re: Game Crashing Bug
Post by: Rubric on September 10, 2008, 07:21:34 am

I've had three crashes.  All of them happen at the moment I try to go from Cell stage to Creature stage.  My cell creature (with legs added) is saved to the sporepedia, but I have to basically start a new game with him at the Creature stage.  In other words, my time line from Cell is lost, and I get no special ability from Cell. 

I've made the transition from Cell to Creature several times without crashing, and have had no crashes anywhere else. 
Title: Re: Game Crashing Bug
Post by: Vaeadin on September 10, 2008, 08:04:59 am
I actually experienced this particular crash last night as well.  I've wiped out two other species with no crash but this one was terrible about it.  I crashed 5-6 times before I found a way out of it.   I've also experienced crashes that are all different.  Sound goes out and i've got about 30 seconds to save before the entire game explodes. Another is I just get a black screen and Spore just closes which is what happened after trying to eliminate that last colony of that species. I've tried updating video and sound card drivers and nada.  One other solution given is to reinstall Spore due to corrupted texture files etc that haven't copied correctly.  I haven't actually tried that one yet.
Title: Re: Game Crashing Bug
Post by: Bonemouse on September 10, 2008, 09:56:26 am

I've had three crashes.  All of them happen at the moment I try to go from Cell stage to Creature stage.  My cell creature (with legs added) is saved to the sporepedia, but I have to basically start a new game with him at the Creature stage.  In other words, my time line from Cell is lost, and I get no special ability from Cell. 

I've made the transition from Cell to Creature several times without crashing, and have had no crashes anywhere else. 

I've had this same exact thing happen to me. It's very frustrating. Out of curiosity, are you using a theme? I have a suspicion that the game crashes when trying to load a bugged out creature (also may be why the game crashes when people go to the planet surface.)
Title: Re: Game Crashing Bug
Post by: smjjames on September 10, 2008, 10:01:12 am
Yeah my game crashes sometimes when I press ctrl + z when im painting something in one of the editors.
Its starting to get really annoying now :-\

Same here, allthough I've only had it with the building editor so far. I'm doing a driver update, so I'll see if that helps.
Title: Re: Game Crashing Bug
Post by: Rubric on September 10, 2008, 10:02:45 am

I've had three crashes.  All of them happen at the moment I try to go from Cell stage to Creature stage. 

I've had this same exact thing happen to me. It's very frustrating. Out of curiosity, are you using a theme? I have a suspicion that the game crashes when trying to load a bugged out creature (also may be why the game crashes when people go to the planet surface.)

Well, it happened on my 1st game, where I was using My Creations as a theme.  It has happened twice when my son was playing, and I really have no idea whether he picked a theme or not.  He can't even read, so he could have picked a random sporecast that I was subscribed too.

However, last night, I did pick a theme (gamingsteve sporecast), and had no problem making the transistion.  Then again, it didn't actually load any of the creatures from that sporecast.  Or at least, I haven't seen them yet.

Your theory makes sense though.
Title: Re: Game Crashing Bug
Post by: TheNewGuy on September 10, 2008, 10:06:00 am
My game crashes after i defended my homeworld against invaders and i want to go to orbit. In all other cases it works, except after the invasion. And this problem exists only for my homeworld. When i defend one of my colonies and go after that into orbit it works just fine.

This is exactly the same problem I have.  The game crashes every time I try to go back into orbit from my planet, but only after combat has started.  I can enter and exit all I want before I get attacked, but AFTER I get attacked, I can't leave the surface.  There's also no problem entering and leaving other planets, just the homeworld.

Has anybody else found any way to fix it?  I'd prefer not to just start deleting files if there's a better fix.
Title: Re: Game Crashing Bug
Post by: smjjames on September 10, 2008, 10:09:01 am
Sounds like Spore is having alot of problems, despite its hype. Maybe EA pushed them hard so that they didn't do enough beta testing? I'm not saying we should have waited longer (I would be dead if I said that here, lol), just that EA may have had a hand in this.

Also, its likely a side effect of the fact that Spore is pioneering new territory so to speak with programming, so there are more problems than usual.
Title: Re: Game Crashing Bug
Post by: TFGoose on September 10, 2008, 02:57:47 pm
Sounds like Spore is having alot of problems, despite its hype. Maybe EA pushed them hard so that they didn't do enough beta testing? I'm not saying we should have waited longer (I would be dead if I said that here, lol), just that EA may have had a hand in this.

Also, its likely a side effect of the fact that Spore is pioneering new territory so to speak with programming, so there are more problems than usual.

I hear what you're saying here, but I was under the impression that EA gave Maxis quite a bit of breathing room on this project, probably a lot moreso than many other publishers do.  Heck, probably more than EA gives on virtually anything else under their corporate umbrella.  It's Maxis, and they were creating the next big franchise, so EA gave them a wide berth.

All that said, the game does seem to suffer from a few bugs (like the crashing mentioned here) that went curiously undiscovered (or at least unaddressed) prior to release.  Furthermore, and perhaps more disturbingly, there are clearly some balancing and AI difficulty issues in Space stage that seem like they should have been right in the face of any beta testers.  I admit I'm having a hard time envisioning a scenario where the difficulty/annoyance factor of the current Space stage (at least, on any difficulty above Normal) wasn't noticed.  And if it was noticed, why wasn't it fixed?  I'm willing to wait for space stations, cybernetics, star destroyers (as in, causing supernovas), advanced diplomacy, and everything else that is better served for an expansion.  And I'm still loving the game right now even with its flaws.  But I really, seriously, don't think it's too much to ask that the game *work* from both a technical and playability standpoint straight out of the original box.

--TFGoose
Title: Re: Game Crashing Bug
Post by: Necrox on September 11, 2008, 04:17:54 am
With regards to your post there Goose, I just hope Maxis remembers your quote in your sig.
Title: Re: Game Crashing Bug
Post by: Bama on September 11, 2008, 04:25:45 am
I shouldn't  have said anything. Game has crashed 4 times today doing different things.  :'(
Title: Re: Game Crashing Bug
Post by: fallout386 on September 11, 2008, 04:39:35 am
People having crash issues do you own SLI cards per chance?

I have noticed with my SLI setup the game has random 'freezes' for about 15-20 seconds and will also sometimes crash entirely. If you switch your nvidia settings to run Spore in single GPU mode then I experience none of these problems. I have tested this playing one day with SLI mode and another with single GPU and have noticed this difference.
Title: Re: Game Crashing Bug
Post by: Bama on September 11, 2008, 04:57:46 am
Just crashed 2 more times...hurray
Title: Re: Game Crashing Bug
Post by: Necrox on September 11, 2008, 05:01:43 am
No SLI, no. My MB and card are both SLI capable, but I don't actually have 2 cards.
Title: Re: Game Crashing Bug
Post by: Bama on September 11, 2008, 05:03:00 am
I dont know what happened. I started over and now it's crashing all the time.
Title: Re: Game Crashing Bug
Post by: TDKenyon on September 11, 2008, 02:15:59 pm
I crash whenever I get to the Grox star "Emillia." If that system is required to beat the Grox, I'll be quite unhappy.
Title: Re: Game Crashing Bug
Post by: Bama on September 11, 2008, 03:01:17 pm
Yeah I save before I enter a system now....it's a pain
Title: Re: Game Crashing Bug
Post by: W8-4Spore on September 11, 2008, 03:28:40 pm
I didn't have any problems until today... Now every time I try to create a new building (House) (I haven't tried with the other types yet) it keeps crashing. Even when I try to open the building editor without loading my game, from the "main menu" page it still crashes. But i've already made like 3-4 different styles of houses and other buildings, and now it won't let me make one
Title: Re: Game Crashing Bug
Post by: Bama on September 11, 2008, 03:55:07 pm
Yeah it sucks....I love love the game but worrying it will crash everytime i do something sucks.
Title: Re: Game Crashing Bug
Post by: Bama on September 11, 2008, 04:51:01 pm
Wow now it's crashing all the time...anyone having this problem ?  :'(